FFmpeg error with video stream


I'm trying to make a stream using a webcam as data input with FFmpeg, but I need it to record a video in addition to the stream. Both features with the same command for a few minutes.

(If placed separately the code of the recording works perfectly since the one of the streaming does not work and presents the same error.)

I tested two different code versions and got the same error for streaming output url.

It's important to also say that everything is right with the server.

FFmpeg code:

ffmpeg -f dshow -rtbufsize 2048M -i "video=Integrated Webcam" -t 300 -c:v libx264 
-segment_atclocktime 1 -segment_format mp4 meuvideo.mp4 -f mpegts -q:v 5 -codec:v 
mpeg1video https://urlexemplo.com.br:8081/rota


    ffmpeg started on 2017-11-20 at 15:52:22
Report written to "ffmpeg-20171120-155222.log"

ffmpeg version 3.3.3 Copyright (c) 2000-2017 the FFmpeg developers

built with gcc 7.1.0 (GCC)
  configuration: --enable-gpl --enable-version3 --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-libmfx --enable-nvenc --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-zlib

  libavutil      55. 58.100 / 55. 58.100
  libavcodec     57. 89.100 / 57. 89.100
  libavformat    57. 71.100 / 57. 71.100
  libavdevice    57.  6.100 / 57.  6.100
  libavfilter     6. 82.100 /  6. 82.100
  libswscale      4.  6.100 /  4.  6.100

libswresample   2.  7.100 /  2.  7.100
  libpostproc    54.  5.100 / 54.  5.100

Input #0, dshow, from 'video=Integrated Webcam':
  Duration: N/A, start: 9581.085000, bitrate: N/A

Stream #0:0: Video: rawvideo (YUY2 / 0x32595559), yuyv422, 640x480, 30 fps, 30 tbr, 10000k tbn, 10000k tbc

https://urlexemplo.com.br:8081/rota: Unknown error

(The application is being written with Node.js and Electron)

I ran the -report command and generated a report. You can not paste directly here because it is too big, can be found in the link:


Regardless of how I write the FFmpeg code it always gives error in the output url. Is there any specific way to stream video with HTTP? Any command that is missing and that justifies the error?

Edit 1:

To test, I put the address udp: //@xxx.xxx: 1234 (xxx.xxx -> IP) instead of the url and the command ran, watched streaming with VLC and it still recorded the video properly during the requested five minutes.

The question remains: Is there any special parameter for working with HTTP addresses?

asked by anonymous 09.11.2017 / 15:47

0 answers