Solution .Net with Membership does not connect to oracle database


I'm trying to run a project on my computer but it reports error in the string:


OracleConnection.ConnectionString is invalid

The same project works normally on the computer where it was started. The Oracle version on both computers is 11g. I removed all oracle from my machine and reinstalled, as did ODAC 4.

The same string I'm using in WebConfig is in the Oracle TNSNames and I connect to the base normally.

I made the connection to the same base in visual studio using Oracle OLE DB, connection also worked.

I have another application that connects to the same bank and it works, the only difference is that this other application has no membership. My Connection String in Webconfig:

    <remove name="LocalSqlServer" />
    <add name="Oracle" providerName="Oracle.DataAccess.Client" connectionString="User ID=User;Password=MinhaSenha;Persist Security Info=True;Data Source=(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = = 1570)))(CONNECT_DATA = (SERVICE_NAME =;Connection Timeout=14400;Max Pool Size=900;" />

Some attempts already made:

  • In ASP.Net Configuration, on providers, I enabled the OracleMembershipProvider option for both Membership Provider and Role Provider.
  • In ASP.Net Configuration, under security, I can not make changes due to error "OracleConnection.ConnectionString is invalid".
  • I commented the line where it points the error, but whenever the DB is called the same error occurs on another line with membership.
  • Refresh the reference to Oracle.DataClient with solution rebuild.

Apparently the two machine configurations are the same: VS2012 and Oracle 11g with ODDAC version

I came to distrust something of the Warning below, but searching the web did not find anything related:


There was a mismatch between the processor architecture of the project   being built "MSIL" and the processor architecture of the reference   "Oracle.DataAccess, Version =, Culture = neutral,   PublicKeyToken = 89b483f429c47342, processorArchitecture = x86 "," x86 ".   This mismatch may cause runtime failures. Please consider changing the   targeted processor architecture of your project through the   Configuration Manager so as to align the processor architectures   between your project and references, or take a dependency on   references with a processor architecture that matches the targeted   processor architecture of your project.

Has anyone experienced something like this before and could it help solve this problem? Some colleagues said that it is annoying to run membership in oracle, really that much trouble?

asked by anonymous 06.07.2016 / 15:19