How to configure ReSharper to NOT add 'summary' comments


When using the ReSharper (StyleCop) 'Remove Unused Directives in File' or 'Remove Redundant Code in File' function to exclude some library from my project, ReSharper removes it, but adds comments throughout the project :

// </copyright>
// <summary>
// </summary>
// -------------------------------------------------------------------------

I have already tried several tutorials on how to disable this interaction, but so far I have not found anything that really works. Things I've tried:

link link link link

Among others ..

Can anyone help on how to disable this feature?

Thank you in advance!

asked by anonymous 22.10.2015 / 19:24

1 answer


After a few days of testing and looking for new ways to try to solve the problem, I was able to solve the problem by disabling the two comment options below:

Inaddition,Idisabledthe"Supress" options in the same settings, but I'm sure it influenced the solution.

If someone did not succeed, or was able to solve this problem in a different way, please publish.

29.10.2015 / 14:58